Quiz: What's the Best Test Method Name?

Which of the following names of test methods do you think to be the best?

[polldaddy poll=5757187]

(Notice that we could leave out "payment_" from the last name if it is clear from the context, i.e. from the fixture [a fancy name for test class] name.)

According to the holy book of Clean Code, the code should make visible the intent as much as possible. According to the testing guru Kent B., a test should be telling a story to its reader - a story about how the code should be used and function. According to these two and my own experiences from reading a lot of (test) core written by other people, the last one is absolutely the best. However you have the right to disagree and discuss :-)

PS: I firmly believe that calling a test method "test()" should be punishable.

Tags: opinion java quality


Copyright © 2020 Jakub Holý
Powered by Cryogen
Theme by KingMob